#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)ส[ัา][สด]|สัตว์|เหี้ย"
Local $sString = "สัด" & @CRLF & _
"สาท" & @CRLF & _
"สาด" & @CRLF & _
"สัตว์" & @CRLF & _
"เหี้ย" & @CRLF & _
"ดกเดกเ" & @CRLF & _
"ดกเดกเ" & @CRLF & _
"กดเกดดเ" & @CRLF & _
"พะำ" & @CRLF & _
"นรีน" & @CRLF & _
"อือเ" & @CRLF & _
"ด้พะ" & @CRLF & _
"ะด้ด" & @CRLF & _
"เด้ดเ"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")