# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:\b|\d+)([a-z])|[\d+ +!.@]/\U\1/g;t' <<< "Th3 qu!ck br0wn f0x jumps 0v3r th3 l@zy d0g. "