#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?:\b|\d+)([a-z])|[\d+ +!.@]"
Local $sString = "Th3 qu!ck br0wn f0x jumps 0v3r th3 l@zy d0g. "
Local $sSubst = "\U\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)