// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?:\b|\d+)([a-z])|[\d+ +!.@]").unwrap();
let string = "Th3 qu!ck br0wn f0x jumps 0v3r th3 l@zy d0g. ";
let substitution = "\\U\\1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}