import Foundation
let pattern = #"\[Remote IP\]:\s\[(?<remoteIp>([0-9\.]{0,}))\]"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
****************************************************************
[2020-12-31 10:07:04,967] [INFO ][c.s.d.s.activityLauncher.access] *********************[ ACCESS-END Info ]*********************
- [Date]: [2020-12-31 10:07:04.967]
- [Remote IP]: [10.30.20.20]
- [Correlation ID]: [03d93d63-9e42-4dac-9e0b-1252d149e297]
- [Trace ID]: [e7ca75e6b6d2dac0]
- [Span ID]: [34de12785de46a27]
- [Method]: [dmIndivCheck]
- [RESPONSE TIME]: [49ms]
- [Args]: [[IndivRequestParamDTO(DCOL_DATA_ID=EDP20201231100704849-MXNI_DCP_1, ACTIVITY_ID=EDP_DCOL_RESPONSE_DECISION, MODEL_UUID=fbb02026-6ace-4901-be2e-93c2d7341af6)]]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)