const regex = /^( *)(?!# console)((console\.log)+.*)$/img;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^( *)(?!# console)((console\\.log)+.*)$', 'img')
const str = `console.log(22);
//console.log('this is:', result)
//console.log
console.log
console.log
console.log
console.log
console.log
console.log
console.log`;
const subst = `//$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);