# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:\G(?!^)|\b)\d(?=\d{0,2}\.\d{1,3}\.)/x/gm;t' <<< "10.101.11.11
101.11.11.11
2003.12.11"