#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?:\G(?!^)|\b)\d(?=\d{0,2}\.\d{1,3}\.)"
Local $sString = "10.101.11.11" & @CRLF & _
"101.11.11.11" & @CRLF & _
"2003.12.11"
Local $sSubst = "x"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)