use strict;
my $str = 'N-U0 U0-M1
M1-T9 T9-R10 R10-E19
E19-L100 L100-B';
my $regex = qr/(?:(?<exitingN>N)|((?<exitingF>[UMTREL]{1})(?<exitingNumber>[0-9]+)))-((?<enteringB>B)|(?:(?<enteringF>[UMTREL]{1})(?<enteringNumber>[0-9]+)))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}