package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([\d|*]{6})([\d|*]+)`)
var str = `9911112111111`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}