#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(http)s?:\/\/[^#?]+"
Local $sString = "https://url.spec.whatwg.org/#url-syntax" & @CRLF & _
"https://url.spec.whatwg.org/" & @CRLF & _
"https://www.google.com/search?q=Regular+Expressions&num=1000" & @CRLF & _
"https://www.google.com/search"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")