package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^;\s*|;\s*$`)
var str = `; foo ;bar;
foo ;bar;
; foo ;bar
foo ;bar`
var substitution = "<DEL>"
fmt.Println(re.ReplaceAllString(str, substitution))
}