import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^;\\s*|;\\s*$";
final String string = "; foo ;bar;\n"
+ "foo ;bar;\n"
+ "; foo ;bar\n"
+ "foo ;bar";
final String subst = "<DEL>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}