Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
(?<=[\.?!]\s|^)([a-z])|(\bi(?=\b|'))
/
gm
Input 1
1
New
the quick brown fox jumped over the lazy dog. the dog did not like this! why would the fox jump over him? the dog did not understand. why am i short? it's not lke i'm not eating or anything, i'm just short!
Substitution
\U$0