use strict;
my $str = 'the quick brown fox jumped over the lazy dog. the dog did not like this! why would the fox jump over him? the dog did not understand.
why am i short? it\'s not lke i\'m not eating or anything, i\'m just short!';
my $regex = qr/(?<=[\.?!]\s|^)([a-z])|(\bi(?=\b|'))/mp;
my $subst = '\\U$0';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";