# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=[\.?!]\s|^)([a-z])|(\bi(?=\b|'))"
test_str = ("the quick brown fox jumped over the lazy dog. the dog did not like this! why would the fox jump over him? the dog did not understand.\n\n"
"why am i short? it's not lke i'm not eating or anything, i'm just short!")
subst = "\\U$0"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.