import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\]\\()https://github\\.com/[^\\/]+/[^\\/]+/(?:issues|pull)/(\\d+)";
final String string = "- Should convert: https://github.com/versionpress/versionpress/issues/123\n"
+ "- Should convert: https://github.com/versionpress/versionpress/pull/123\n"
+ "- Should convert: (https://github.com/versionpress/versionpress/issues/123)\n"
+ "- Should NOT convert (already a Markdown link): [#123](https://github.com/versionpress/versionpress/issues/123)\n";
final String subst = "[#$1]($0)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}