# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<!\]\()https://github\.com/[^\/]+/[^\/]+/(?:issues|pull)/(\d+)"
test_str = ("- Should convert: https://github.com/versionpress/versionpress/issues/123\n"
"- Should convert: https://github.com/versionpress/versionpress/pull/123\n"
"- Should convert: (https://github.com/versionpress/versionpress/issues/123)\n"
"- Should NOT convert (already a Markdown link): [#123](https://github.com/versionpress/versionpress/issues/123)\n")
subst = "[#$1]($0)"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.