import Foundation
let pattern = #"(?<!\]\()https://github\.com/[^\/]+/[^\/]+/(?:issues|pull)/(\d+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
- Should convert: https://github.com/versionpress/versionpress/issues/123
- Should convert: https://github.com/versionpress/versionpress/pull/123
- Should convert: (https://github.com/versionpress/versionpress/issues/123)
- Should NOT convert (already a Markdown link): [#123](https://github.com/versionpress/versionpress/issues/123)
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = ##"[#$1]($0)"##
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)