#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(as|aox)\d+\.vs-prod-domain\.com"
Local $sString = "as01.vs-prod-domain.com" & @CRLF & _
"as02.vs-prod-domain.com" & @CRLF & _
"aox01.vs-prod-domain.com" & @CRLF & _
"aox02.vs-prod-domain.com" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")