const regex = /(as|aox)\d+\.vs-prod-domain\.com/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(as|aox)\\d+\\.vs-prod-domain\\.com', 'gm')
const str = `as01.vs-prod-domain.com
as02.vs-prod-domain.com
aox01.vs-prod-domain.com
aox02.vs-prod-domain.com
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}