re = /^((?i)REQ[0-9]{1,10};)+((?i)REQ[0-9]{1,10};?)$|^((?i)REQ[0-9]{1,10};)$/m
str = 'REQ2;rEq1;'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end