# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<!\S)(?:(@[^\s@]+)(?!\S)[^h]*(?:h(?!ttp)[^h]*)*+)?\K((?:https?|ftp|file):\/\/\S+)//gm;t' <<< "@test https://stackoverflow.com/questions/ask
Hello @username you need to check this http://github.com and @username you need to https://stackoverflow.com/questions/ask
This is an email test@test.com http://www.test.test
Hello @username you need to check this htt://github.com and @username you need to
Hello @username check this https://regex101.com/r/D3Imn9/1"