#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<!\S)(?:(@[^\s@]+)(?!\S)[^h]*(?:h(?!ttp)[^h]*)*+)?\K((?:https?|ftp|file)://\S+)"
Local $sString = "@test https://stackoverflow.com/questions/ask" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Hello @username you need to check this http://github.com and @username you need to https://stackoverflow.com/questions/ask" & @CRLF & _
"" & @CRLF & _
"This is an email test@test.com http://www.test.test" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Hello @username you need to check this htt://github.com and @username you need to " & @CRLF & _
"" & @CRLF & _
"Hello @username check this https://regex101.com/r/D3Imn9/1"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)