#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[^\W_](?:[\w.-]*[^\W_])?@[^\W_](?:\w*[^\W_])?(?:[.-]\w*[^\W_])*\.[^\W_]{2,}$"
Local $sString = "jasmin.martinez@tester.co.rolisa-brown.king@tester.co.ro" & @CRLF & _
"jasmin-martinez@tester.co" & @CRLF & _
"lisabrown.king@tester.co" & @CRLF & _
"jasmin-martinez@teste-r.co" & @CRLF & _
"j@teste-r.co"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")