$re = '/^hsla?\((?:(-?\d+(?:deg|g?rad|turn)?),\s*((?:\d{1,2}|100)%),\s*((?:\d{1,2}|100)%)(?:,\s*((?:\d{1,2}|100)%|0(?:\.\d+)?|1))?|(-?\d+(?:deg|g?rad|turn)?)\s+((?:\d{1,2}|100)%)\s+((?:\d{1,2}|100)%)(?:\s+((?:\d{1,2}|100)%|0(?:\.\d+)?|1))?)\)$/mi';
$str = 'hsl(123deg, 100%, 0%)
hsl(123, 100%, 0%)
hsl(123rad 100% 0%)
hsla(123grad, 100%, 0%, 0)
hsla(-123turn 100% 0% 1)
hsla(1 100% 0% 50%)
bad ones
hsl(123deg, 100%, 0%)
hsl(123, 100%, 0%)
hsl(123ad 100% 0%)
hsla(123grd, 100%, 0%, 0)
hsla(-123trn 100% 0% 1)
hsla(1 a% 0% 50%)
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);