#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)<\s*script\s+.+?(?=src\s*=\s*['"]).+?(?=.bundle.js).bundle.js\s*["'](?:\s*>|\s*\/\s*>)(?:\s*<\s*\/\s*script\s*>)?"
Local $sString = "<script type="text/javascript" src="inline.a4f139a42f2ec94463d6.bundle.js"></script>" & @CRLF & _
"<script type="text/javascript" src="polyfills.456a9bac641ef5f0139a.bundle.js"></script><script type="text/javascript" src="sw-register.b73048fe3d9f8a1e7ae5.bundle.js"></script>" & @CRLF & _
"<script>" & @CRLF & _
"</script>" & @CRLF & _
"<script type="text/javascript" src="vendor.8fa530543a5178055143.bundle.js"></script>" & @CRLF & _
"<script type="text/javascript" src="main.196eab45c86ac53c856e.bundle.js"></script>" & @CRLF & _
"</body>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")