# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<\s*script\s+.+?(?=src\s*=\s*['\"]).+?(?=.bundle.js).bundle.js\s*[\"'](?:\s*>|\s*\/\s*>)(?:\s*<\s*\/\s*script\s*>)?"
test_str = ("<script type=\"text/javascript\" src=\"inline.a4f139a42f2ec94463d6.bundle.js\"></script>\n"
"<script type=\"text/javascript\" src=\"polyfills.456a9bac641ef5f0139a.bundle.js\"></script><script type=\"text/javascript\" src=\"sw-register.b73048fe3d9f8a1e7ae5.bundle.js\"></script>\n"
"<script>\n"
"</script>\n"
"<script type=\"text/javascript\" src=\"vendor.8fa530543a5178055143.bundle.js\"></script>\n"
"<script type=\"text/javascript\" src=\"main.196eab45c86ac53c856e.bundle.js\"></script>\n"
"</body>\n")
matches = re.finditer(regex, test_str, re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.