import Foundation
let pattern = #"<\s*script\s+.+?(?=src\s*=\s*['"]).+?(?=.bundle.js).bundle.js\s*["'](?:\s*>|\s*\/\s*>)(?:\s*<\s*\/\s*script\s*>)?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
<script type="text/javascript" src="inline.a4f139a42f2ec94463d6.bundle.js"></script>
<script type="text/javascript" src="polyfills.456a9bac641ef5f0139a.bundle.js"></script><script type="text/javascript" src="sw-register.b73048fe3d9f8a1e7ae5.bundle.js"></script>
<script>
</script>
<script type="text/javascript" src="vendor.8fa530543a5178055143.bundle.js"></script>
<script type="text/javascript" src="main.196eab45c86ac53c856e.bundle.js"></script>
</body>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)