package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?sm)<(script|style)>.*?</(script|style)>`)
var str = `<script>
document.write('<style>p {color:red}</style>')
</script>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}