re = /<(script|style)>.*?<\/(script|style)>/m
str = '<script>
document.write(\'<style>p {color:red}</style>\')
</script>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end