Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
\bp+[a@\*]?[e3\*\W_]+d+[\*0o](?:(?:ph|f)il(?:[e3\*\W_]|ia))?\b
/
gm
Input 1
1
New
p3do pedo pedophile pedophilia paedofile pedofile peeedophilia pedophil3 p3d0 ped0 p*do peedo DO NOT CAPTURE pedogogy