use strict;
my $str = '-1:23';
my $regex = qr/.(?=.?$)/mp;
my $subst = '<span>$0</span>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";