re = /^(?!'+$)[a-zA-Z']+(?: +[a-zA-Z']+)*$/m
str = 'John Smith
Steve Mc\'millan
Hill St\'
\'\'\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end