package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\s*([a-zA-Z]).*\s+([a-zA-Z])\S+$`)
var str = `a A BCD eFG`
var substitution = "\U$1$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}