use strict;
my $str = 'a A BCD eFG';
my $regex = qr/^\s*([a-zA-Z]).*\s+([a-zA-Z])\S+$/mp;
my $subst = '\\U$1$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";