re = /^\s*([a-zA-Z]).*\s+([a-zA-Z])\S+$/m
str = 'a A BCD eFG'
subst = '\\U$1$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result