package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)TRACE\([&](\w+)(\s*)[,](\s*)(\w+)(\s*)[,](\s*)(\w+)(\s*)[,]`)
var str = `TRACE(&logger_mr , DEBUG_2, NULL,UdpPathMgmtLogger::entranceStr_sc);
TRACE(&logger_mr,DEBUG_2, NULL,
UdpPathMgmtLogger::entranceStr_sc);
TRACE(&logger_mr , DEBUG_2 , NULL ,
UdpPathMgmtLogger::entranceStr_sc;`
var substitution = "TRACE\("
fmt.Println(re.ReplaceAllString(str, substitution))
}