# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"TRACE\([&](\w+)(\s*)[,](\s*)(\w+)(\s*)[,](\s*)(\w+)(\s*)[,]"
test_str = ("TRACE(&logger_mr , DEBUG_2, NULL,UdpPathMgmtLogger::entranceStr_sc);\n"
"TRACE(&logger_mr,DEBUG_2, NULL,\n"
" UdpPathMgmtLogger::entranceStr_sc);\n\n"
"TRACE(&logger_mr , DEBUG_2 , NULL ,\n"
" UdpPathMgmtLogger::entranceStr_sc;")
subst = "TRACE\\("
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.