$re = '/\x/m';
$str = 'The FF0000 lion roared';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);