# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"DB(1000|0[1-9]|[1-9]\d{0,2})\.DB[XBDW](1000|0[1-9]|[1-9]\d{0,2})\.(0|10|[1-9])"
test_str = ("|\"DB1.DBX1.0\"|\"DB1000.DBB1000.0\"|\"DB18.DBD4.0\"|\"DB99.DBW999.0\"|\n\n"
"such that DB[1-1000].DB[X,B,D,W][1-1000.0-10]\n\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE | re.DOTALL)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.