package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)((aa)*(bb)*)|(a(aa)*b(bb)*)`)
var str = `aaabbb`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}