$re = '/^(?=.*\bgood foo\b)(?!.*\bgood koo\b).*$/m';
$str = 'some text good foo and some text and good koo
good foo and some text (no indication of koo)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);