#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?i)\btodo\b.*(?i)\bjundan\b.*"
Local $sString = "// todo - daniel junior - test" & @CRLF & _
"// todo jundan test" & @CRLF & _
"// TODO -jundan- asaksakjhdakjshdas" & @CRLF & _
"// TODOjundan - alijsakljsldk" & @CRLF & _
"/////// tODO-jundan batata"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")