package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?i)\btodo\b.*(?i)\bjundan\b.*`)
var str = `// todo - daniel junior - test
// todo jundan test
// TODO -jundan- asaksakjhdakjshdas
// TODOjundan - alijsakljsldk
/////// tODO-jundan batata`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}