using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bkey=""((?:ktm(?:-e|-(?:[^e\W]|e[^d\W])\w*)*-)?abcd(?:-e|-(?:[^e\W]|e[^d\W])\w*)*)""";
string input = @" 1. object{one=""ab-vwxc"",two=""value1"",key=""abcd-eest-ed-xyz-bnn"",four=""obsoleteValues""}
2. object{one=""ab-vwxc"",two=""value1"",key=""abcd-eest-xyz-bnn"",four=""obsoleteValues""}
3. object{one=""ab-vwxc"",two=""value1"",key=""abcd-eest-xyz-bnn-ed"",four=""obsoleteValues""}
4. object{one=""ab-vwxc"",two=""value1"",key=""abcd-e-xyz-bnn"",four=""obsoleteValues""}
5. object{one=""ab-vwxc"",two=""value1"",key=""ktm-bb-abcd-e-xyz-bnn"",four=""obsoleteValues""}
6. object{one=""ab-vwxc"",two=""value1"",key=""ktm-bb-abcd-ed-xyz-bnn"",four=""obsoleteValues""}
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}