const regex = new RegExp('\\bkey="((?:ktm(?:-e|-(?:[^e\\W]|e[^d\\W])\\w*)*-)?abcd(?:-e|-(?:[^e\\W]|e[^d\\W])\\w*)*)"', 'gm')
const str = ` 1. object{one="ab-vwxc",two="value1",key="abcd-eest-ed-xyz-bnn",four="obsoleteValues"}
2. object{one="ab-vwxc",two="value1",key="abcd-eest-xyz-bnn",four="obsoleteValues"}
3. object{one="ab-vwxc",two="value1",key="abcd-eest-xyz-bnn-ed",four="obsoleteValues"}
4. object{one="ab-vwxc",two="value1",key="abcd-e-xyz-bnn",four="obsoleteValues"}
5. object{one="ab-vwxc",two="value1",key="ktm-bb-abcd-e-xyz-bnn",four="obsoleteValues"}
6. object{one="ab-vwxc",two="value1",key="ktm-bb-abcd-ed-xyz-bnn",four="obsoleteValues"}
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}