import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{\\s*method: ?[\"'](\\w+)[\"']\\s*\\};";
final String string = " { method: \"GET\" };";
final String subst = "{method: \"$1\", credentials: \"same-origin\"};";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}