$re = '/([a-zA-Z]{1,3})(\d{1,4})([a-zA-Z]{0,3})/m';
$str = 'E2360YAR
R1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);