package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\s*(\w{2,})\s*(\w{2,})\w*|\s*$`)
var str = `Mark Full
Mark Full
Mark Full dsad
Mark
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}